[MPlayer-users] compile errors

Gábor Lénárt lgb at lgb.hu
Thu Oct 11 21:55:02 CEST 2001

On Thu, Oct 11, 2001 at 03:07:19PM -0400, Sloan Poe wrote:
> I apologize if this has been covered, but if it has I haven't seen it
> anywhere.  
> Anyway.. I've tried several of the latest versions of mplayer and gotten
> the same errors.  I run gcc 3.0.1 and have even tried downgrading to
> 2.95 yet still I get this error.  The weird part is that up until
> yesterday mplayer compiled fine. 

Interesting thing, since with gcc 2.95 I've never had got such a problem.
With 3.0.1: yes. I've sent even bug reports to the gcc team ...

> here's the error by the way:
> mot_est_mb.c: In function `FindSubPel':
> mot_est_mb.c:843: Internal error: Segmentation fault
> Please submit a full bug report,
> with preprocessed source if appropriate.
> See <URL:http://www.gnu.org/software/gcc/bugs.html> for instructions.
> make[1]: *** [mot_est_mb.o] Error 1
> make[1]: Leaving directory `/home/mrklaw/main/encore'
> make: *** [encore/libencore.a] Error 2

As you can see, this is a gcc bug! So we can't do anything.
Please send a bugreport to the gcc team, and not for us.

> Does anyone out there have any insight into what's causing this error?

Yes. gcc.

PS: I did not understand why users drop us with problems like this.
Maybe you can send bugreports on your wife or something next time :)

- Gabor

More information about the MPlayer-users mailing list