SUMMARY: Re: [Mplayer-users] Install linux mplayer as 'not-root' ??

martin laurberg martin_laurberg at
Thu Apr 19 17:17:33 CEST 2001

Hi everyone!
Thanks for the replys on installing mplayer without
root priviliges!
As suggested I configured using the --with-win32libdir

1)  copying the file codecs.conf to

2)  ./configure

3) Changing top of Makefile to contain:

OWNER = martin
GROUP = martin
prefix = /home/martin/programs/mplayer/main
Still I got complains that the file /etc/mplayer.conf
could not be found. I couldn't find this file anywhere
so I tried changing mplayer.c to point to a dummy
(empty) file in my directory (and recompiled).

When starting mplayer the film starts for 1 sec and
then stops... It looks like
a problem other AthlonTbird users have (??)...

************************LOG FILE: *************

[martin at oku bin]$ ./mplayer ~/video/my_video_divx.avi
-vo x11
MPlayer 0.11cvs-010418-06:45  (C) 2000-2001 Arpad
Gereoffy <arpi at>
Reading config file:
Reading config file: /home/martin/.mplayer/config
Reading /home/martin/.mplayer/codecs.conf: 15 audio &
26 video codecs
Font /home/martin/.mplayer/font/font.desc loaded
successfully! (140 chars)
Detected AVI file format!
==> Found video stream: 0
==> Found audio stream: 1
stream_seek: WARNING! Can't seek to 0x82166DF4 !
VIDEO:  [DIV3]  480x352  24bpp  23.98 fps  922.8 kbps
(112.6 kbyte/s)
[V] filefmt:3  fourcc:0x33564944  size:480x352 
fps:23.98  ftime:=0.0417
Found audio codec: [mp3acm] drv:4 (MPEG layer-3)
Loading DLL:
/home/martin/programs/mplayer/codecs/l3codeca.acm  OK
AUDIO: samplerate=44100  channels=2  bps=2
Found video codec: [divxds] drv:4 (DivX ;-) (MS MPEG-4
X11 running at 1280x1024 depth: 32
Loading DLL:
/home/martin/programs/mplayer/codecs/  OK
DivX setting result = 0
VO: [x11] 480x352 => 480x352  BGR32
Sharing memory.
X11 color mask:  R:FF0000  G:FF00  B:FF
Audio buffer size: 61952 bytes, delay: 0.351s
Start playing...
Initial PTS delay: -0.351 sec  (calculated: -0.309)
stream_seek: WARNING! Can't seek to 0x4500C1AA !  10% 
 5%  2.2%
Exiting... (End of file)
vo: uninit!
[martin at oku bin]$   
*************************** END LOGFILE *************

I run  Linux Mandrake 7.2 (XFree86 4.0.1, patch level
28mdk) on a



Do You Yahoo!?
Get your free address at
or your free address at

Mplayer-users mailing list
Mplayer-users at

More information about the MPlayer-users mailing list