[MPlayer-dev-eng] RTMP playback with optional space-separated parameters broken... :´-(

Reimar Döffinger Reimar.Doeffinger at gmx.de
Sun Jul 15 19:43:53 CEST 2012

On Sun, Jul 15, 2012 at 06:01:51PM +0200, Manuel Reimer wrote:
> Reimar Döffinger wrote:
> >I didn't have time for it. However I believe someone complained about
> >it for FFmpeg already, so I suspect it has nothing to do with MPlayer
> >but with either FFmpeg or even librtmp itself...
> Can you please give me some information on how to debug this problem?

I don't have an idea so far. Obviously finding the exact commit that
broke it via bisection is a good way to get a start.

> I tried to check out older versions of ffmpeg (did this as long as I
> finally got a build that fails to compile) but "ffplay" seems to
> never have worked with the "space separated parameter" syntax. At
> least I wasn't able to get it to do so.

To be honest I have no idea whether it worked with ffplay, I just can't
see how it would have worked with MPlayer then.

> Then I tried several things with mplayer directly and found out,
> that the "rtmp" request seems to go *always* through ffmpeg code.
> Wasn't it possible to make mplayer use "librtmp" directly?

No, never. Really. There are/were two rtmp implementations in FFmpeg:
just rtmp and librtmp-based.
So one thing you could try is if it will suddenly start working if you
disable librtmp (thus forcing it to use the other implementation)...
Without recompiling you can also try "rtmphttp://" instead of "rtmp://",
that should never go through librtmp.
If that really is the case, I think you will need some way to provide
FFmpeg options for streams, there seems to be no support for that so far.
And the "space separated" thing probably is a bad idea, since the main
URL can validly contain spaces...

More information about the MPlayer-dev-eng mailing list