[MPlayer-dev-eng] RTMP playback with optional space-separated parameters broken... :´-(

Manuel Reimer Manuel.Spam at nurfuerspam.de
Sun Jul 15 18:01:51 CEST 2012

Reimar Döffinger wrote:
> I didn't have time for it. However I believe someone complained about
> it for FFmpeg already, so I suspect it has nothing to do with MPlayer
> but with either FFmpeg or even librtmp itself...

Can you please give me some information on how to debug this problem?

I tried to check out older versions of ffmpeg (did this as long as I finally got 
a build that fails to compile) but "ffplay" seems to never have worked with the 
"space separated parameter" syntax. At least I wasn't able to get it to do so.

Then I tried several things with mplayer directly and found out, that the "rtmp" 
request seems to go *always* through ffmpeg code. Wasn't it possible to make 
mplayer use "librtmp" directly?

I really need a fix for this and if needed, I'll try to fix this on my own. I'm 
working on a Firefox addon, which somewhat depends on "gecko-mediaplayer" and 
tries to play back "rtmp" streams using this plugin. Without the "space 
separated parameters" nearly no stream works, as the "autodetection" of the 
playback parameters usually fails for me...

Thank you very much for any help...

I guess I'll now try to download older revisions of MPlayer and continue my 
endless tries to find a revision, where the problem doesn't exist...



More information about the MPlayer-dev-eng mailing list