[MPlayer-dev-eng] mplayer on kfreebsd
Reinhard Tartler
siretart at tauware.de
Thu Apr 22 22:24:00 CEST 2010
On Thu, Apr 22, 2010 at 21:50:42 (CEST), Reinhard Tartler wrote:
> The other thing I've noticed is that kfreebsd already defines a 'struct
> keymap'. I therefore propose to rename the to 'struct m_keymap'
>
> Index: libvo/video_out.h
> ===================================================================
> --- libvo/video_out.h (revision 31057)
> +++ libvo/video_out.h (working copy)
> @@ -269,11 +269,11 @@
> extern char *monitor_vfreq_str;
> extern char *monitor_dotclock_str;
>
> -struct keymap {
> +struct m_keymap {
> int from;
> int to;
> };
> -int lookup_keymap_table(const struct keymap *map, int key);
> +int lookup_keymap_table(const struct m_keymap *map, int key);
> struct vo_rect {
> int left, right, top, bottom, width, height;
> };
Uoti asked me on irc to clarify what exactly breaks. It actually breaks here:
In file included from libvo/vo_directfb2.c:44:
libvo/video_out.h:267: error: redefinition of 'struct keymap'
This is because libvo/vo_directfb2.c #includes sys/kd.h, which in turn
includes sys/kbio.h, which defines another 'struct keymap'. In order to
fix this build error, I propose to rename the struct in mplayer, which
requires patching several files.
--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4
More information about the MPlayer-dev-eng
mailing list