[MPlayer-dev-eng] [PATCH] Add DVB teletext support

Uoti Urpala uoti.urpala at pp1.inet.fi
Sat Oct 31 15:54:38 CET 2009


On Sat, 2009-10-31 at 15:26 +0100, Francesco Lavra wrote:
> On Wed, 2009-10-28 at 18:35 +0100, Diego Biurrun wrote:
> > On Sat, Oct 24, 2009 at 07:33:07PM +0200, Francesco Lavra wrote:
> > > 
> > > --- libmpcodecs/dec_teletext.h	(revision 29796)
> > > +++ libmpcodecs/dec_teletext.h	(working copy)
> > > @@ -23,7 +23,22 @@
> > >  #ifndef MPLAYER_DEC_TELETEXT_H
> > >  #define MPLAYER_DEC_TELETEXT_H
> > >  
> > > +typedef struct tt_param_s {
> > > +    char *device;  ///< teletext device
> > > +    int format;    ///< teletext display format
> > > +    int page;      ///< start teletext page
> > > +    int lang;      ///< primary language code
> > > +} tt_param_t;
> > 
> > The _t namespace is reserved for POSIX, don't invade it.
> 
> Changed typedef from tt_param_t to tt_params

Drop the '_s' from the struct name and then just use 'struct tt_param'
in other code instead of defining a typedef. Such "_s" suffixes are
pointless; the name has to preceded by "struct" in every use anyway so
the suffix can only make code harder to read, and the only possible
namespace conflicts would be with "enum tt_param" or "union tt_param"
which are unlikely to occur. There is no reason to add typedef names for
general structs, and it's an especially bad idea to use a type name like
'tt_params' that does not use any convention to distinguish it from
symbol names.




More information about the MPlayer-dev-eng mailing list