[MPlayer-dev-eng] [PATCH] Switch libavutil macros instead of defining our own

Michael Niedermayer michaelni at gmx.at
Sat Feb 24 23:25:00 CET 2007


Hi

On Sat, Feb 24, 2007 at 08:58:38PM +0100, Roberto Togni wrote:
> On Sat, 24 Feb 2007 19:23:05 +0100
> Michael Niedermayer <michaelni at gmx.at> wrote:
> 
> [...]
> > > @@ -78,40 +73,40 @@
> > >  static void rmff_dump_fileheader(rmff_fileheader_t *fileheader, char *buffer) {
> > >  
> > >    if (!fileheader) return;
> > > -  fileheader->object_id=BE_32(&fileheader->object_id);
> > > -  fileheader->size=BE_32(&fileheader->size);
> > > -  fileheader->object_version=BE_16(&fileheader->object_version);
> > > -  fileheader->file_version=BE_32(&fileheader->file_version);
> > > -  fileheader->num_headers=BE_32(&fileheader->num_headers);
> > > +  fileheader->object_id=AV_RB32(&fileheader->object_id);
> > > +  fileheader->size=AV_RB32(&fileheader->size);
> > > +  fileheader->object_version=AV_RB16(&fileheader->object_version);
> > > +  fileheader->file_version=AV_RB32(&fileheader->file_version);
> > > +  fileheader->num_headers=AV_RB32(&fileheader->num_headers);
> > 
> > as you already change it what about also vertically aligning it :)
> > 
> 
> Please don't. It won't look any better 

fileheader->object_id=AV_RB32(&fileheader->object_id);
fileheader->size=AV_RB32(&fileheader->size);
fileheader->object_version=AV_RB16(&fileheader->object_version);
fileheader->file_version=AV_RB32(&fileheader->file_version);
fileheader->num_headers=AV_RB32(&fileheader->num_headers);

vs.

fileheader->object_id     =AV_RB32(&fileheader->object_id);
fileheader->size          =AV_RB32(&fileheader->size);
fileheader->object_version=AV_RB16(&fileheader->object_version);
fileheader->file_version  =AV_RB32(&fileheader->file_version);
fileheader->num_headers   =AV_RB32(&fileheader->num_headers);

i think it not only looks better but it is more readable but thats surely
just MHO


> and it will require more
> cosmetics everytime something it's changed if you want to keep the
> alignment.

everytime is a exageration, anyway it was just a suggestion ...

[...]

-- 
Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

Concerning the gods, I have no means of knowing whether they exist or not
or of what sort they may be, because of the obscurity of the subject, and
the brevity of human life -- Protagoras
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/mplayer-dev-eng/attachments/20070224/cbef19b4/attachment.pgp>


More information about the MPlayer-dev-eng mailing list