[MPlayer-dev-eng] [PATCH] Switch libavutil macros instead of defining our own
rxt at rtogni.it
Sat Feb 24 19:46:25 CET 2007
On Sat, 24 Feb 2007 18:35:10 +0100
Reimar Döffinger <Reimar.Doeffinger at stud.uni-karlsruhe.de> wrote:
> attached patch replaces MIN, MAX, BE_32 and BE_16 in some places with
> the libavutil equivalent.
> Do you think this is okay despite it's size?
> I assume it would also fix
> http://bugzilla.mplayerhq.hu/show_bug.cgi?id=767 along the way, though
> that is not really the main intention (and could be done by copying the
> definitions from rmff.c instead).
About the header includes, shouldn't it be
like it's done in real.c for md5.h ?
Also real.c #include "mpbswap.h", that line should be removed too since
it's useless after this patch.
For rmff.c you can make the patch much shorter by
#define BE_16(x) AV_RB16(x)
#define BE_32(x) AV_RB32(x)
but I accept also your version of the patch, in my opinion this code is
getting so different from xine that we can stop considering xine
version as upstream and take our code as a fork that is developed
More information about the MPlayer-dev-eng