[MPlayer-dev-eng] [PATCH] Apple Remote support
Diego Biurrun
diego at biurrun.de
Mon Aug 13 10:27:32 CEST 2007
On Mon, Aug 13, 2007 at 03:38:41PM +0800, Ulion wrote:
>
> such a long grammer check, thank you, and here is the updated patch.
>
> --- configure (revision 24050)
> +++ configure (working copy)
> @@ -3571,6 +3575,42 @@
> +
> + // Now search I/O Registry for matching devices.
> + ioReturnValue = IOServiceGetMatchingServices(kIOMasterPortDefault, hidMatchDictionary, &hidObjectIterator);
Please try to keep lines below 80 characters.
> --- input/ar.c (revision 0)
> +++ input/ar.c (revision 0)
> @@ -0,0 +1,384 @@
> +
> + if ((*hidDeviceInterface)->open(hidDeviceInterface, kIOHIDOptionsTypeSeizeDevice) != kIOReturnSuccess)
> + // TODO: cooperate correctly with other apps using Remote Control Wrapper 2.0 above
> + // after open exclusive mode failed, try to send a request to other apps
> + // and wait for a moment someone release it.
Again, please try to keep lines below 80 characters, it makes things
more readable. Especially for multiline comments it makes no sense.
This applies everywhere.
> --- input/ar.h (revision 0)
> +++ input/ar.h (revision 0)
> @@ -0,0 +1,43 @@
> +
> +#ifndef INPUT_AR_H_
> +#define INPUT_AR_H_
> +
> +#endif /* INPUT_AR_H */
This is inconsistent, drop the underscore at the end.
> --- etc/input.conf (revision 24050)
> +++ etc/input.conf (working copy)
> @@ -100,6 +100,21 @@
>
> +AR_VUP volume 1
> +AP_VDOWN volume -1
I assume it should be AR_ and not AP_ here..
Diego
More information about the MPlayer-dev-eng
mailing list