[MPlayer-dev-eng] [PATCH] big vf_osd update
Jason Tackaberry
tack at sault.org
Wed Sep 14 21:28:35 CEST 2005
Hi,
Incorporating the suggestions received by Reimar and Michael, as well as
the documentation fixes offered by Wanderer, attached is an updated
vf_osd patch with many changes from the last. Here is an overview:
* Removed max/min macros and converted clipping code to if/else
statements for improved readability.
* Removed TRUE/FALSE defines in favor of 1/0.
* Ensure all buffers and strides are aligned to 16 byte
boundaries.
* Removed custom colorspace conversion code and rewrote to use
Swscaler.
* Removed optional width/height filter parameters. Now the OSD is
always the display size and will get scaled to mpi size for
blending. If the user needs a fixed and known OSD size, he can
specify scale/expand/dsize on the filter chain before vf_osd.
* Removed gettimeofday() in favor of GetTimer()
* Adding new invalidated rectangles is now O(1) instead of O(n)
* Use %%"REG_c" instead of %%ecx
* Remove grow_array() function and use realloc() instead.
* Improve slave command argument parsing to properly deal with
malformed commands.
* Fixed a bug where colorspace conversion was being done
needlessly for global alpha changes.
* control() returns CONTROL_OK for VFCTRL_PAUSE_UPDATE; mplayer.c
checks this return value in the pause loop and will sleep longer
if it is not handled. (Pause loop now sleeps the same amount of
time as before if no osd filter is loaded.) Tested gmplayer to
ensure pause loop changes created no ill effects.
* Removed loadfile-while-paused handling from patch (it didn't
belong), so mplayer.c patch reduced to only vf_control calls for
VFCTRL_PAUSE_UPDATE.
* Merged most of the documentation suggestions from Wanderer, but
rewrote some paragraphs and the man page entry to reflect above
design changes, so those could benefit from review.
This should address all of the concerns raised. Hopefully there's light
at the end of the tunnel. :) Thanks again to everyone for your feedback
so far.
Cheers,
Jason.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: vf_osd-2005-09-14.diff
Type: text/x-patch
Size: 66278 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/mplayer-dev-eng/attachments/20050914/79a9887c/attachment.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 229 bytes
Desc: This is a digitally signed message part
URL: <http://lists.mplayerhq.hu/pipermail/mplayer-dev-eng/attachments/20050914/79a9887c/attachment.pgp>
More information about the MPlayer-dev-eng
mailing list