[MPlayer-dev-eng] ogm subtitles are a little weird

Andriy N. Gritsenko andrej at lucky.net
Mon Mar 22 12:12:09 CET 2004


    I used to play all with version 0.92 and now I've tried last CVS and
I found two weird things:

1. I must now run mplayer _manually_ from command line to see subtitles.
Nor -sid nor -slang never worked. I can't use -sid X since I never know
what is first text substream, it may be 2,3 or even 4, so I can't find
out it before I play and then I have to manually run mplayer. I can't use
-slang either since ogm format may define language only in comment and
that is optional. It's too weird for me since I used to play video by
just pushing 'Enter' from Midnight Commander or by clicking on it from
gui filebrowser. All old versions of MPlayer played it well and now it
want me do two manual operations to play each file. Any other format
except ogm never want me do such weird thing.

2. I found some files (Angelic Layer DVD rip from Anime-Galaxy) where
subtitles behavior is weird too: previous line doesn't disappear from
screen until new one displays. So line may present on the screen for
unknown time and it strange to see the line for a minute of silence.
Other players (for example windows players) show these subtitles ok.

    So, please, writer of that part, get rid of these two things. If you
want an example file then just ask me.

    With best wishes.

More information about the MPlayer-dev-eng mailing list