[MEncoder-users] ffmpeg 0.9 Difficulties (was: How to transcode MTS files recorded by Panasonic HDC-SD100 camera?)

R.L. Horn lists at eastcheap.org
Fri Feb 17 15:07:15 CET 2012

On Fri, 17 Feb 2012, Carl Eugen Hoyos wrote:

> R.L. Horn <lists <at> eastcheap.org> writes:
>> (however, I've had problems recently with git versions...most
>> notably an utter inability to decode H264)
> Are you really sure you posted this to ffmpeg-user or trac?

I'm quite sure I didn't.  I don't follow ffmpeg-user for a start.

What I was trying to do was get a new mplayer built.  I tried a few git 
ffmpegs over two or three days (just letting the configure script grab 
them) without success, then, eventually, managed to make it work by 
building against the old 0.9 release.  Even then, I had to correct some 
nonsensical #ifdefs in the ffmpeg source.

At this point, I'd spent Grud knows how many hours on the project and was 
pretty disgusted.  I figured I'd wait a couple of days, get new ffmpeg 
sources and, if that was a bust, submit a bug report.  Then, I completely 
forgot about it until yesterday.

I wrote, "utter inability," but that's not quite true.  I had some YouTube 
.mp4s lying around that decoded fine, but everything else I tried resulted 
in thousands of "Concealing...errors" lines.  The same was true for both 
mplayer and ffplay.

Oh, and as for the not having 0.9 headers and libraries around, that's 
just about the API; nothing to do with any ffmpeg 0.9 deficiencies. 
Obviously, there's no harm in installing the versioned shared libraries.

More information about the MEncoder-users mailing list