[MEncoder-users] AC3 and Strange Video Playback

Nigel Arnold nkarnold at googlemail.com
Thu Dec 20 14:19:12 CET 2007


I'm getting a problem creating any MPEG4 AVI with any AC3 audio track.

I've tried RC2 and also a 25088 build as provided by Sherypa

I''ve stripped back to a very basic bare command line,

mencoder dvd://1 -dvd-device R:\  -oac lavc  -ovc lavc -lavcopts
vcodec=mpeg4:vbitrate=1024:acodec=ac3:abitrate=192  -ofps
24000/1001 -Chapter 03-03  -o "AC3 Test.avi"

The resulting .avi file -
1. The video plays about 2-3 times faster than speed than normal (like a
Fast forward) in VLC, and WMP
2. The video is not seekable, as soon as I position in VLC, the video ends,
in WMP If i seek, the video stops, audio still plays and takes about 10
minutes for the video / audio to start playing again.

This appears to be only related to AC3, as if I choose libmp3lame or
libfaac, the video's are fine.

I've tried the above command with a much earlier build 21190 and it works
fine. the resulting video file plays fine in VLC, WMP and MPlayer

Any Ideas

Thx in advance


More information about the MEncoder-users mailing list