[MEncoder-users] sync problem with -oac faac

Victor Condino un1tz3r0 at gmail.com
Tue Feb 28 20:51:12 CET 2006

On 2/28/06, Jonathan <jonathan at kc8onw.net> wrote:
> Victor Condino wrote:
> [snip]
> > my main issue after doing a few
> > test encodes is with faac... it seems that when using -oac faac the
> > audio leads by several seconds (!)... not sure if sync drifts yet, so
> > a possible workaround might be manually determining an offset and
> > encoding with it, but still... i tried reencoding using x264 and -oac
> > mp3lame and sync was fine.
> >
> > anyone else experienced this sync problem with faac? anone know of a solution?
> It may not be the same issue but when I was encoding to x264 with CVS
> from a couple of months back I found that the video was delayed by
> frame_duration*max_bframes.  I don't know if it was an encoding or
> decoding issue and I wound up hacking around it by using
> raw[audio|video], muxing to matroska and setting an audio delay in
> matroska.  I was also using Vorbis audio instead of faac because I never
> got faac working on windows and the files where destined for PC only
> playback anyway.

hrmmm... that is interesting, although i'm pretty sure that my problem
is being caused by the faac audio export module and not the x264 video
export mod... like i said i ran controls, and in fact since i have
also tried encoding to -ovc xvid and even -ovc copy (source material
was MPEG-2 program stream, i.e. DVD VOB) with -oac faac and -oac
mp3lame, and in all cases, the audio is extremely (in the range of a
few seconds) ahead of video in ALL cases where -oac faac is used, and
fine with any other combination of output codecs.

this is just vexing me because i'd really like to take the finished
avi, and then use avidump to extract the raw AVC and AAC streams, then
use the mpeg4ip tools to mux them into a true MPEG-4 container format.
i'm not terribly concerned that WMP most likely won't play that any
time soon/maybe ever... i do spend about 50/50 of my time in windows,
but as far as watching media goes i generally just reboot into linux
and fire up mplayer, since i keep all my media on my server and play
it off an NFS share (yes, i could set up samba on the server... but
WMP bugs me anyway :D... hate that lack of keyboard control.)

i might try a few more test encodes to see exactly what the sync
offset is and whether it drifts/by how much per-second. if it's not
drifting and the offset seems constant for all encodes, i suppose an
easy workaround would be to just specify the offset manually to
mencoder, but in any case i think that this is probably a more serious
issue that needs to be addressed by the developers. i might try
grabbin the latest CVS of everything (mplayer/faac/x264) and see if
it's been resolved yet... but i'm already using CVS builds from no
earlier than last week. maybe if i get REALLY bored after doing more
test encodes, i'll take a look at the faac export module code in the
mplayer source and see if i can't fix it myself...

perhaps i should repost this thread as a cross-post on the mplayer-dev list?

More information about the MEncoder-users mailing list