[MEncoder-users] problems with target size and xvid

Alexey com at nforum.de
Mon Apr 11 15:42:06 CEST 2005

No ideas? I have encoded more movies and they were all fine. Yesterday I
tried the old one again and it got much to big again. Could it be that
"max_bframes=2" somehow prevent xvid from calculating the target size



On Thu, 2005-02-17 at 02:32 +0100, Alexey wrote:
> Hi everybody,
> I am using mplayer-1.0_pre5-r5 and xvid-1-0.2 on gentoo linux and I have
> a problem with the
> target size. I dont get the size I specify. I use mencoder as encoder
> and these are the settings I use.
> mencoder dvd://1 -dvd-device /path/to/dvd -nosound
> -xvidencopts :bitrate=-1790943:pass=1:vhq=4:me_quality=6:chroma_me:quant_type=mpeg:max_bframes=2:gmc -o /dev/null
> mencoder dvd://1 -dvd-device /path/to/dvd -nosound -ovc xvid
> -xvidencopts :bitrate=-1790943:pass=2:vhq=4:me_quality=6:chroma_me:quant_type=mpeg:max_bframes=2:gmc -o output.avi
> Although this should have produced a filesize of about 1.7GB I got
> 2.8GB. Could it be that the second pass needs the avi file of the first
> pass? I thought that "xvid-twopass.stats" contains all the data needed
> for second pass. I tested the target size option before with smaller
> values and got pretty exact sizes so it worked. But after encoding three
> times with such a big target size I didnt got anything even close to it.
> This is very annoying as this encoding took my PC about 30 hours and I
> will have to do it again.
> So did I do anything wrong or is this a bug in xvid?
> Regards
> Alexey
> _______________________________________________
> MEncoder-users mailing list
> MEncoder-users at mplayerhq.hu
> http://mplayerhq.hu/mailman/listinfo/mencoder-users

More information about the MEncoder-users mailing list