[FFmpeg-user] FFMPEG run out of memory

Carl Eugen Hoyos cehoyos at ag.or.at
Mon May 9 15:37:33 CEST 2016

ionut <ionut.raducanu <at> webland.ro> writes:

> Usually I get from cpu a constant 300-400% (4core) but now 
> is more in 100-150% and sometimes over 300%, and the memory 
> usage is over 95% constant. What is wrong ?

So does FFmpeg run out-of-memory or are you just reporting 
that it allocates a lot of memory?

Very generally: Are you reporting a leak (valgrind output 
needed) or oom?

And are you reporting that what you tried worked fine with 
older versions of FFmpeg but fails with a newer one?

> ffmpeg version N-78733-g0f31d40-syslint Copyright (c) 
> 2000-2016 the FFmpeg developers

In a case like yours, testing current FFmpeg is absolutely 

>    built with gcc 4.4.7 (GCC) 20120313 (Red Hat 4.4.7-16)
>    configuration: --prefix=/usr/local/cpffmpeg --enable-shared 
> --enable-nonfree --enable-gpl --enable-pthreads 
> --enable-libopencore-amrnb

> --enable-decoder=liba52 

Note that this option has no effect (does not exist) 
since about a decade.

I wonder if the filter system tries to read input as fast as 
possible, no matter how slow or fast the later filters in 
the chain work...

Carl Eugen

More information about the ffmpeg-user mailing list