[FFmpeg-user] V4L2 recording results in invalid data & buffer still owned errors.

Louis Rossmann l.a.rossmann at gmail.com
Sun Sep 21 07:25:48 CEST 2014

On Wed, Sep 17, 2014 at 1:50 AM, Louis Rossmann <l.a.rossmann at gmail.com>

> Louis Rossmann <l.a.rossmann <at> gmail.com> writes:
>>> > So that messed up configure line is not Gentoo's
>>> > fault, but all mine. :(
>>> Then please reconfigure with "./configure --enable-gpl"
>>> and add the external libraries you need, do NOT add any
>>> --disable-* flags and do NOT add any --extra-cflags /
>>> --extra-ldflags except those needed for library detection.
>>> Your current executable is intentionally slow.
>>> Carl Eugen
>>> _______________________________________________
>>> ffmpeg-user mailing list
>>> ffmpeg-user at ffmpeg.org
>>> http://ffmpeg.org/mailman/listinfo/ffmpeg-user
>> I've done everything I can with my executable, however, the problem
>> persists.
>> If I run a recording, it works. if I stop the recording, there is little
>> I can do short of reboot the system to record a second video using the V4L2
>> device. I've tried on an Ubuntu desktop and a Gentoo laptop. Do you have
>> any suggestions? Kernel 3.14 was a quick fix but sadly that did not last
>> long. :(
> I decided to try on a different computer with a fresh install and the
> problem persists. I can only record once before having to reboot.
> I have two of the same device. What is interesting is, even after I have
> run out of recording tries with one device, I can try again with the next
> and it works - but of course, only for one time.
> The only other software I can find that allows me to simultaneously
> capture raw video from an HDMI source is $1000 on Windows 7. If someone can
> fix V4L/ffmpeg so it works properly with these devices, I'd be willing to
> match the $1k in donations. I absolutely love how no frills this is - no
> crap, no tons of menus, no junk I don't need, just type a line tell it how
> to encode and it gives me files I can easily edit. I love it... I just hate
> rebooting my machine for each take. I have an SSD, but still, cmon! :)

I'm checking out cvlc now. I love ffmpeg, but if it doesn't work, no reason
to bang my head against the wall. The documentation isn't nearly as simple
for cvlc as it is for ffmpeg - were there any specific pages that helped
you get out of cvlc what you were looking for?

More information about the ffmpeg-user mailing list