[FFmpeg-user] V4L2 recording results in invalid data & buffer still owned errors.

artwait artwait at gmail.com
Wed Sep 17 23:45:57 CEST 2014

Louis Rossmann <l.a.rossmann <at> gmail.com> writes:

> > Louis Rossmann <l.a.rossmann <at> gmail.com> writes:
> >>
> >> > So that messed up configure line is not Gentoo's
> >> > fault, but all mine. :(
> >>
> >> Then please reconfigure with "./configure --enable-gpl"
> >> and add the external libraries you need, do NOT add any
> >> --disable-* flags and do NOT add any --extra-cflags /
> >> --extra-ldflags except those needed for library detection.
> >>
> >> Your current executable is intentionally slow.
> >>
> >> Carl Eugen
> >>
> >> _______________________________________________
> >> ffmpeg-user mailing list
> >> ffmpeg-user <at> ffmpeg.org
> >> http://ffmpeg.org/mailman/listinfo/ffmpeg-user
> >>
> >
> > I've done everything I can with my executable, however, the problem
> > persists.
> >
> > If I run a recording, it works. if I stop the recording, there is 
little I
> > can do short of reboot the system to record a second video using the 
> > device. I've tried on an Ubuntu desktop and a Gentoo laptop. Do you 
> > any suggestions? Kernel 3.14 was a quick fix but sadly that did not 
> > long. :(
> >
> >
> I decided to try on a different computer with a fresh install and the
> problem persists. I can only record once before having to reboot.
> I have two of the same device. What is interesting is, even after I have
> run out of recording tries with one device, I can try again with the next
> and it works - but of course, only for one time.
> The only other software I can find that allows me to simultaneously 
> raw video from an HDMI source is $1000 on Windows 7. If someone can fix
> V4L/ffmpeg so it works properly with these devices, I'd be willing to 
> the $1k in donations. I absolutely love how no frills this is - no crap, 
> tons of menus, no junk I don't need, just type a line tell it how to 
> and it gives me files I can easily edit. I love it... I just hate 
> my machine for each take. I have an SSD, but still, cmon! :)

So, I've now tried using VLC's command line (cvlc) to record from v4l2, and 
it works flawlessly. Not a single failure; no reboots required.

So for the time being, I'm giving up on ffmpeg and will use VLC. As of 
yesterday's ffmpeg build, the problem still exists.

FYI, here's the VLC command line I tested with. There are additional 
parameters to play with of course, but this was enough to prove to me that 
it works:

cvlc v4l2:// :v4l2-vdev="/dev/video0" --sout 

More information about the ffmpeg-user mailing list