[FFmpeg-user] V4L2 recording results in invalid data & buffer still owned errors.

Louis Rossmann l.a.rossmann at gmail.com
Sat Sep 6 15:04:28 CEST 2014

On Sat, Sep 6, 2014 at 7:22 AM, Carl Eugen Hoyos <cehoyos at ag.or.at> wrote:

> Louis Rossmann <l.a.rossmann <at> gmail.com> writes:
> > *  built on Sep  4 2014 22:48:40 with gcc 4.8.3 (Gentoo
> I know this doesn't help you with your problem but this
> configure line looks (or if you like "feels") *completely*
> broken...
> > *[rawvideo  <at>  0xfb5040] Warning: not compiled with
> > thread support, using thread emulation*
> ... and unfortunately my feelings are right!
> Again, this will not help you but is there nobody who
> uses Gentoo and wants to fix this?
> My todo list is unfortunately long enough (and I don't
> use Gentoo).
> To make sure I am not misunderstood: This isn't about
> removing one bad option from the configure line but to
> fix the system that creates this absurd mess!
> Carl Eugen
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user


Thank you for your reply.

Firstly, I fixed my problem. I would like to share how - I dumped 3.16.1
kernel and compiled 3.14.14. This problem is 100% solved, and all runs very
stable. The V4L2 drivers in 3.16.1 are terrible for USB devices. They
worked for my integrated laptop webcam, but did not work for this. Also CPU
usage went down a lot when I compiled 3.14.14 for capturing video.

Secondly, I did not use Gentoo's portage system to compile ffmpeg, I did it
by hand, since I could not get v4l2 support combined in with any
combination of USE flags. So that messed up configure line is not Gentoo's
fault, but all mine. :(

Hopefully this helps someone else who is driving themselves nuts with this
same problem Lesson learned, use a stable kernel!

More information about the ffmpeg-user mailing list