[FFmpeg-user] A/V sync issues & more with MediaPortal recording of ClearQAM

Mr M redpenguinmail at gmail.com
Mon Feb 3 23:35:52 CET 2014

To give a little bit of background this is my setup:

MediaPortal 1.6.0 (Win 7) with HDHomeRun Dual (ClearQAM)

I've recorded TSes from this setup that worked perfectly using FFMPEG with
the follow command:

"ffmpeg.exe -i FILE.ts -vcodec libxvid -vtag XVID -vf scale=720:480 -aspect
4:3 -maxrate 1200k -b:v 981k -qmin 3 -qmax 5 -bufsize 4096 -deinterlace
-acodec libmp3lame -b:a 128k -ac 2 -async 1 OUT.avi"

On every recording I've gotten so far this method has worked like a charm.

Yet on channel seems to have some sort of strange "MPEGin" going on.

ffmpeg reports the following streams:

[mpeg2video @ 024b9900] Invalid frame dimensions 0x0.
    Last message repeated 3 times
[mpegts @ 024be860] PES packet size mismatch
[NULL @ 041e3ba0] start time is not set in estimate_timings_from_pts
[mpegts @ 024be860] PES packet size mismatch
[mpegts @ 024be860] Could not find codec parameters for stream 3 (Audio:
ac3 ([129][0][0][0] / 0x0081), 0 channels): unspecified sample format
Consider increasing the value for the 'analyzeduration' and 'probesize'
Input #0, mpegts, from '\\\d\manual - MSNBC - 2014-02-02.ts':
  Duration: 03:06:10.68, start: 0.078578, bitrate: 3754 kb/s
  Program 137
    Stream #0:0[0x40](eng): Audio: ac3 ([129][0][0][0] / 0x0081), 48000 Hz,
stereo, fltp, 192 kb/s
    Stream #0:1[0x41](spa): Audio: ac3 ([129][0][0][0] / 0x0081), 48000 Hz,
stereo, fltp, 192 kb/s
    Stream #0:2[0x30]: Video: mpeg2video (Main) ([2][0][0][0] / 0x0002),
yuv420p(tv), 704x480 [SAR 10:11 DAR 4:3], max. 3080 kb/s, 29.83 fps, 29.97
tbr, 90k tbn, 59.94 tbc
  No Program
    Stream #0:3[0x42](spa): Audio: ac3 ([129][0][0][0] / 0x0081), 0 channels

The 0:1 and 0:3 seem to be dead as you hear silence on 0:1 and 0:3 shows no

Also it seems during the commericals the video size is not staying the same.

Like the programming is 704:480 yet commericals can go like 540:X and other
random sizes.

VLC can play the file fine also changing sizes during commericals but
ffmpeg seems to lose A/V sync the more times it hits a commerical break.

More information about the ffmpeg-user mailing list