[FFmpeg-user] libv4l2: error dequeuing buf: Resource temporarily unavailable

llarevo at gmx.net llarevo at gmx.net
Sat Jul 21 16:09:21 CEST 2012

> > capturing from analog cards Terratec Cinergy 400 TV and Terratec Cinergy
> > XS USB isn't possible in ffmpeg versions from 0.7.13 to 0.11.1. The
> > cards are proved OK for Linux and working with all of my other apps
> > (tvtime, xawtv, mplayer, mencoder). See my discussion on linux-media
> > http://article.gmane.org/gmane.linux.drivers.video-input-infrastructure/51055
> > 
> > I'm using Fedora 17 and tried different versions from 0.5.x wih
> > different hardware. The cards were tuned to Channel E10 (europe-west)
> > and had good quality signal (analog cable).
> > 
> > The test results are
> >                           Cinergy XS USB  Cinergy 400 TV
> > 0.5.10                    OK              OK
> Oh so it worked without libv4l2 at some point... That's interesting.
> That's hard to tell like this what change could have cause the regression
> since we have no way of testing; would you mind trying to git bisect on
> libavdevice/v4l2.c between 0.5 and 0.7 and see if one of the commit
> introduced that issue?

I can try. But could you please describe the necessary steps a bit more
detailed? I am not very familiar with git. A list of commands and short
instructions and where to start or some howto should be sufficient. 

Thank You

More information about the ffmpeg-user mailing list