[FFmpeg-user] libv4l2: error dequeuing buf: Resource temporarily unavailable

Clément Bœsch ubitux at gmail.com
Fri Jul 20 21:19:33 CEST 2012

On Fri, Jul 20, 2012 at 06:31:11PM +0200, llarevo at gmx.net wrote:
> Hi,
> capturing from analog cards Terratec Cinergy 400 TV and Terratec Cinergy
> XS USB isn't possible in ffmpeg versions from 0.7.13 to 0.11.1. The
> cards are proved OK for Linux and working with all of my other apps
> (tvtime, xawtv, mplayer, mencoder). See my discussion on linux-media
> http://article.gmane.org/gmane.linux.drivers.video-input-infrastructure/51055
> I'm using Fedora 17 and tried different versions from 0.5.x wih
> different hardware. The cards were tuned to Channel E10 (europe-west)
> and had good quality signal (analog cable).
> The test results are
>                           Cinergy XS USB  Cinergy 400 TV
> 0.5.10                    OK              OK

Oh so it worked without libv4l2 at some point... That's interesting.
That's hard to tell like this what change could have cause the regression
since we have no way of testing; would you mind trying to git bisect on
libavdevice/v4l2.c between 0.5 and 0.7 and see if one of the commit
introduced that issue?

> 0.7.13                    OK              broken (differently, s.b.)
> 0.8.12                    OK              broken (differently, s.b.)
> 0.9.2                     OK              broken (differently, s.b.) 
> 0.9.2 (--enable-libv4l2)  OK              broken (like in subject)
> 0.10.4 (--enable-libv4l2) OK              broken (like in subject)
> 0.11.1                    OK              broken (differently, s.b.)
> 0.11.1 (--enable-libv4l2) OK              broken (like in subject)


Clément B.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 490 bytes
Desc: not available
URL: <http://ffmpeg.org/pipermail/ffmpeg-user/attachments/20120720/a23167b7/attachment.asc>

More information about the ffmpeg-user mailing list