[FFmpeg-user] FFmpeg issues with MP4?

Erik Lat erik.lat at htbindustries.org
Mon Dec 5 23:13:11 CET 2011

   Hey guys, I have been running a little encoder service on an xinetd 
port for some time now. Basically it reads data in and filters through a 
WAV->MP3 conversion and outputs the data as an MP3. It has been working 
fine for many different formats (VBR mp3, ogg, wav, etc) but it seems to 
be choking on MP4 audio.

   I have tried running the file through the processes manually on the 
command line which works fine, but I was curious if you guys might know 
why it doesn't work in my xinetd server. From the service file you will 
see that I'm logging FFmpeg's stderr to a file. There's a message about 
estimating duration from bitrate, but this message pops up for WAV, OGG, 
and MP3 files as well without issue.

   Here's an example of what I'm doing:

user at host$ file file.ogg
file.ogg: Ogg data, Vorbis audio, stereo, 44100 Hz, ~128000 bps, 
created by: Xiph.Org libVorbis I
user at host$ cat file.ogg | nc localhost 9615 > a.mp3
user at host$ file file.mp3
file.mp3: Audio file with ID3 version 2.4.0, contains: MPEG ADTS, layer 
III, v1, 128 kbps, 44.1 kHz, JntStereo
user at host$ file file.mp4
file.mp4: ISO Media, MPEG v4 system, version 2
user at host$ cat file.mp4 | nc localhost 9615 > a.mp3
** hangs indefinitely **
user at host$ cat 16B_-_Inbetween_Your_Choice.m4a | 
/usr/local/bin/ffmpeg.sh > a.mp3
** this WORKS **

Attached are the files I'm working with. NOTE: to test you may need to 
setup an entry for the 'ffmpeg' service in your /etc/services file.

ffmpeg:     xinetd service file
ffmpeg.sh:  xinetd script file

I am using FFmpeg version 0.6.3-rpmfusion, on Fedora 14, but have also 
tried with FFmpeg version 0.7.8 on Gentoo with the same result.


Erik Lat
Systems Engineer
HTB Industries, Inc.
P: 312.857.4797
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ffmpeg.sh
Type: text/x-shellscript
Size: 273 bytes
Desc: not available
URL: <http://ffmpeg.org/pipermail/ffmpeg-user/attachments/20111205/0fd3b208/attachment.bin>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: ffmpeg
URL: <http://ffmpeg.org/pipermail/ffmpeg-user/attachments/20111205/0fd3b208/attachment.ksh>

More information about the ffmpeg-user mailing list