[FFmpeg-devel] [PATCH 02/10] avfilter/avgblur_vulkan: use FF_ARRAY_ELEMS instead of magic number

Wu Jianhua jianhua.wu at intel.com
Thu Nov 18 06:24:41 EET 2021


Signed-off-by: Wu Jianhua <jianhua.wu at intel.com>
---
 libavfilter/vf_avgblur_vulkan.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/libavfilter/vf_avgblur_vulkan.c b/libavfilter/vf_avgblur_vulkan.c
index 253290663b..243e932f35 100644
--- a/libavfilter/vf_avgblur_vulkan.c
+++ b/libavfilter/vf_avgblur_vulkan.c
@@ -115,7 +115,7 @@ static av_cold int init_filter(AVFilterContext *ctx, AVFrame *in)
 
         ff_vk_set_compute_shader_sizes(ctx, shd, (int [3]){ CGS, 1, 1 });
 
-        RET(ff_vk_add_descriptor_set(ctx, s->pl_hor, shd, desc_i, 2, 0));
+        RET(ff_vk_add_descriptor_set(ctx, s->pl_hor, shd, desc_i, FF_ARRAY_ELEMS(desc_i), 0));
 
         GLSLF(0, #define FILTER_RADIUS (%i)                     ,s->size_x - 1);
         GLSLC(0, #define INC(x) (ivec2(x, 0))                                 );
@@ -160,7 +160,7 @@ static av_cold int init_filter(AVFilterContext *ctx, AVFrame *in)
 
         ff_vk_set_compute_shader_sizes(ctx, shd, (int [3]){ 1, CGS, 1 });
 
-        RET(ff_vk_add_descriptor_set(ctx, s->pl_ver, shd, desc_i, 2, 0));
+        RET(ff_vk_add_descriptor_set(ctx, s->pl_ver, shd, desc_i, FF_ARRAY_ELEMS(desc_i), 0));
 
         GLSLF(0, #define FILTER_RADIUS (%i)                     ,s->size_y - 1);
         GLSLC(0, #define INC(x) (ivec2(0, x))                                 );
-- 
2.17.1



More information about the ffmpeg-devel mailing list