[FFmpeg-devel] [FFmpeg-cvslog] Merge commit '7cb1d9e2dbbe5bf4652be5d78cdd68e956fa3d63'

James Almer jamrial at gmail.com
Fri Oct 13 00:35:00 EEST 2017

On 10/12/2017 6:12 PM, Helmut K. C. Tessarek wrote:
> On 2017-10-12 16:04, James Almer wrote:
>> Sounds like pkg-config is not providing you with the required deps.
>> Since you're doing a static build with static external libraries, try
>> adding "--pkg-config-flags=--static" to your configure line.
> Which makes no sense, since I checked the pkg_config files and they look
> fine.
> Anyway, I tried --pkg-config-flags=--static. It did not help.

bzip2 and zlib show up as dependencies of freetype2 in the
"Requires.private" section of its .pc file in your system, right? If
you're using an static build of freetype2, pkg-config needs to be run
with --static to actually get the required ldflags for said dependencies.

Now, the issue here is libbluray adding freetype2 ldflags directly
instead of setting freetype2 as a dependency, much like freetype2 sets
bzip2 and zlib.

> But as I've suspected I had to add -lbz2 -lz to LDFLAGS. Now it works.

I suppose that if that change is done to libbluray's .pc file (namely,
adding a "Requires.private: freetype2 fontconfig" line or similar, if i
understand this correctly), you'll be able to use the --static
pkg-config-flag and remove most if not all of these LDFLAGS you list below.

> export LDFLAGS="$LDFLAGS -lstdc++ -lass -lfontconfig -lexpat -lenca
> -lfribidi -lfreetype -lbz2 -lz -framework CoreText"
>> Adding --static to --pkg-config-flags might let you remove some of these
>> custom ldflags. But probably not all.
> It doesn't look that way.
> Btw, I still get these awful warnings for every file.
> Ronald B. mentioned in another thread:
> -------------------------------------------------------------------------
> From IRC yesterday (gcc=clang here):
> bash-4.4$ gcc /dev/null -Wno-bool-operation -c -o /tmp/x.o && echo success
> clang: warning: /dev/null: 'linker' input unused
> [-Wunused-command-line-argument]
> clang: warning: argument unused during compilation: '-Wno-bool-operation'
> [-Wunused-command-line-argument]
> success
> bash-4.4$ gcc -Wno-bool-operation /tmp/x.c -c -o /tmp/x.o
> -Werror=unused-command-line-argument && echo success
> warning: unknown warning option '-Wno-bool-operation'; did you mean
> '-Wno-bool-conversion'? [-Wunknown-warning-option]
> 1 warning generated.
> successbash-4.4$ gcc -Wno-bool-operation /tmp/x.c -c -o /tmp/x.o
> -Werror=unused-command-line-argument -Werror=unknown-warning-option && echo
> success
> error: unknown warning option '-Wno-bool-operation'; did you mean
> '-Wno-bool-conversion'? [-Werror,-Wunknown-warning-option]
> That last one should allow this to work.
> -------------------------------------------------------------------------
> Can someone please fix this?

Just sent a patch for this.

More information about the ffmpeg-devel mailing list