[FFmpeg-devel] [PATCH 1/2] libavutil: add av_zhb

James Almer jamrial at gmail.com
Tue Mar 17 17:27:12 CET 2015

On 17/03/15 5:28 AM, Reimar Döffinger wrote:
> On 17.03.2015, at 05:08, James Almer <jamrial at gmail.com> wrote:
>> Signed-off-by: James Almer <jamrial at gmail.com>
>> ---
>> Better name (av_zero_high_bits?) and doxygen welcome.
> Maybe av_wrap_intp2? (to align with clip function naming)
> Or av_mod_p2?
> Essentially it does a modulo with a power of 2.
> Otherwise "clear" high bits seems a more natural name than "zero".

Well, the bmi2 instruction uses zero http://www.felixcloutier.com/x86/BZHI.html
Nonetheless, i like av_mod_p2 more than av_zhb, so unless someone else suggests 
something else I'll resend the set using that name.

More information about the ffmpeg-devel mailing list