[FFmpeg-devel] avformat option strange behaviour

Clément Bœsch ubitux at gmail.com
Tue Jul 26 11:56:48 CEST 2011

On Mon, Jul 25, 2011 at 10:44:30PM +0200, Michael Niedermayer wrote:
> On Mon, Jul 25, 2011 at 06:05:36PM +0200, Clément Bœsch wrote:
> > Hi,
> > 
> > It seems the format option parsing is broken in FFmpeg, but I can't figure
> > out why. I still didn't do a git bisect to track down the issue, but
> > someone may have a hint about this.
> if the private muxer context is allocated a bit earlier then avdict
> doesnt work
> ive fixed it
> > 
> > I attached a dummy patch to add an option to a random format, and tried to
> > use it. Unfortunately, the -foobar bla never set the option in the context
> > struct; the option is well recognized and parsed (it fills the options
> > dict), but that dict may not be used. I'm almost certain it's a bug since
> > applying the exact same patch works with libav HEAD.
> libav isnt able to allocate private contexts that early, thats why
> they added avdict to workaround that
> ffmpeg never needed avdict to set muxer specific options, but i was
> foolish enough to switch to it which combined with the different
> place of context allocation caused this bug
> thanks for reporting

Thanks for fixing it :)

Clément B.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 490 bytes
Desc: not available
URL: <http://ffmpeg.org/pipermail/ffmpeg-devel/attachments/20110726/22c941ec/attachment.asc>

More information about the ffmpeg-devel mailing list