[FFmpeg-devel] avformat option strange behaviour

Michael Niedermayer michaelni at gmx.at
Mon Jul 25 22:44:30 CEST 2011

On Mon, Jul 25, 2011 at 06:05:36PM +0200, Clément Bœsch wrote:
> Hi,
> It seems the format option parsing is broken in FFmpeg, but I can't figure
> out why. I still didn't do a git bisect to track down the issue, but
> someone may have a hint about this.

if the private muxer context is allocated a bit earlier then avdict
doesnt work
ive fixed it

> I attached a dummy patch to add an option to a random format, and tried to
> use it. Unfortunately, the -foobar bla never set the option in the context
> struct; the option is well recognized and parsed (it fills the options
> dict), but that dict may not be used. I'm almost certain it's a bug since
> applying the exact same patch works with libav HEAD.

libav isnt able to allocate private contexts that early, thats why
they added avdict to workaround that
ffmpeg never needed avdict to set muxer specific options, but i was
foolish enough to switch to it which combined with the different
place of context allocation caused this bug

thanks for reporting


Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

It is not what we do, but why we do it that matters.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <http://ffmpeg.org/pipermail/ffmpeg-devel/attachments/20110725/e0413d10/attachment.asc>

More information about the ffmpeg-devel mailing list