[FFmpeg-devel] [PATCH 12/12] Rename pixelFormatBpsAVI to pix_fmt_bps_avi and pixelFormatBpsMOV to pix_fmt_bps_mov.

Stefano Sabatini stefano.sabatini-lala
Sat May 15 19:44:03 CEST 2010


The new names are consistent with the FFmpeg style.
---
 libavcodec/rawdec.c |    8 ++++----
 1 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/libavcodec/rawdec.c b/libavcodec/rawdec.c
index 6556322..b4ec2fd 100644
--- a/libavcodec/rawdec.c
+++ b/libavcodec/rawdec.c
@@ -35,7 +35,7 @@ typedef struct RawVideoContext {
     AVFrame pic;             ///< AVCodecContext.coded_frame
 } RawVideoContext;
 
-static const PixelFormatTag pixelFormatBpsAVI[] = {
+static const PixelFormatTag pix_fmt_bps_avi[] = {
     { PIX_FMT_PAL8,    4 },
     { PIX_FMT_PAL8,    8 },
     { PIX_FMT_RGB555, 15 },
@@ -45,7 +45,7 @@ static const PixelFormatTag pixelFormatBpsAVI[] = {
     { PIX_FMT_NONE, 0 },
 };
 
-static const PixelFormatTag pixelFormatBpsMOV[] = {
+static const PixelFormatTag pix_fmt_bps_mov[] = {
     { PIX_FMT_MONOWHITE, 1 },
     { PIX_FMT_PAL8,      2 },
     { PIX_FMT_PAL8,      4 },
@@ -74,11 +74,11 @@ static av_cold int raw_init_decoder(AVCodecContext *avctx)
 
     if (avctx->pix_fmt == PIX_FMT_NONE) {
         if (avctx->codec_tag == MKTAG('r','a','w',' '))
-            avctx->pix_fmt = find_pix_fmt(pixelFormatBpsMOV, avctx->bits_per_coded_sample);
+            avctx->pix_fmt = find_pix_fmt(pix_fmt_bps_mov, avctx->bits_per_coded_sample);
         else if (avctx->codec_tag)
             avctx->pix_fmt = find_pix_fmt(ff_raw_pix_fmt_tags, avctx->codec_tag);
         else if (avctx->bits_per_coded_sample)
-            avctx->pix_fmt = find_pix_fmt(pixelFormatBpsAVI, avctx->bits_per_coded_sample);
+            avctx->pix_fmt = find_pix_fmt(pix_fmt_bps_mov, avctx->bits_per_coded_sample);
     }
 
     context->length = avpicture_get_size(avctx->pix_fmt, avctx->width, avctx->height);
-- 
1.7.0




More information about the ffmpeg-devel mailing list