[FFmpeg-devel] FW: pts/dts generation and index for mpegts (vob)

Erik Van Grunderbeeck erik
Tue Jun 16 23:52:51 CEST 2009


>> Ping. Just want to know if there is any interest in this. If not, will
stop
>> bugging. If yes, would like some comments or just a plain no/yes?

>There is definitely an interest. Patch is huge though and will be long to
>review. Thanks for your work.

> /*
>  * BMP image format decoder
>  * Copyright (c) 2005 Mans Rullgard
>  *

>Copy-paste ?
>Is this code based on something else ?

Yes, I cut & paste the header from another file. Changed. TY

> [...]
>
> typedef struct AVAttachmentParseContext {
> 	double				m_pts;
> } AVAttachmentParseContext;

>Can you please remove the leading m_ ?

Sure. Done.

> [...]
> 
> static int attachment_decode_frame(AVCodecContext *avctx,
>                             void *data, int *data_size,
>                             AVPacket *avpkt)
> [...]

>We'd like to have code consistently named, so please avoid pContext,
>etc.. I think ctx is is good.
>Same for the indentation.
>
>I think this would better have a CODEC_ID_DVDNAVDATA.

I apologize for the naming conventions, I should probably have tried to
stick to the ones FFMpeg uses from the beginning. Same for the indentation,
and my use of TAB's that is frowned up here. 

On the CODEC_ID_DVDNAVDATA: I checked the source's for any use of the codec
Id's, and found the attachment ones. It's not used though, but my thought
was that it would make sense to try to use an existing one in a "generic"
way, such that when later on people want to extend ege the ASF scripting
support, it could be delivered through the same mechanism. Then again,
perhaps not. Thoughts would be much appreciated.

Erik





More information about the ffmpeg-devel mailing list