[FFmpeg-devel] FFMpeg on SH4 (STi7109)

Måns Rullgård mans
Thu Nov 27 17:49:26 CET 2008

Jean-Michel Hautbois wrote:
> 2008/11/26 Jean-Michel Hautbois <jhautbois at gmail.com>
>> 2008/11/26 M?ns Rullg?rd <mans at mansr.com>
>>> Jean-Michel Hautbois wrote:
>>> > O, it compiles and runs on the SH4 device.
>>> >
>>> > I would like to "make test", but I don't know how to run it on the
>>> device.
>>> > Is there some tricky way ?
>>> There is an easy way.  Simply make your FFmpeg build tree visible to the
>>> device over NFS or otherwise (doesn't need to be same as on build host),
>>> and add --target-exec='ssh targetname' --target-path=/build/root/on/target
>>> to your configure options.  Then "make test" should run the tests on the
>>> target device.  You can override those parameters on the make command line
>>> using the names TARGET_EXEC and TARGET_PATH.
>> OK, I will try  that tomorrow.
> OK, I just tried it, but it is not working.
> I ran make test after specifying the target exec and path
> I have an error:
> ffmpeg_g -y -flags +bitexact -dct fastint -idct simple -sws_flags
> +accurate_rnd+bitexact -f image2 -vcodec pgmyuv -i
> /root/applications/tests/vsynth1/%02d.pgm -an -f rawvideo
> /root/applications/./tests/data/vsynth.ref.yuv
> make: *** [regtest-ref] Erreur 255

That is not the full line that should be printed.  Please copy and paste
the entire line of the command.

> When I am lauching this exact command through ssh, with the same command
> line than make test, it works.

There is evidently a mismatch somewhere.  Double-check the --target-exec
argument, and check the value of TARGET_EXEC in config.mak.

M?ns Rullg?rd
mans at mansr.com

More information about the ffmpeg-devel mailing list