[FFmpeg-devel] FFMpeg on SH4 (STi7109)

Jean-Michel Hautbois jhautbois
Thu Nov 27 16:06:17 CET 2008

2008/11/26 Jean-Michel Hautbois <jhautbois at gmail.com>

> 2008/11/26 M?ns Rullg?rd <mans at mansr.com>
>> Jean-Michel Hautbois wrote:
>> > O, it compiles and runs on the SH4 device.
>> >
>> > I would like to "make test", but I don't know how to run it on the
>> device.
>> > Is there some tricky way ?
>> There is an easy way.  Simply make your FFmpeg build tree visible to the
>> device over NFS or otherwise (doesn't need to be same as on build host),
>> and add --target-exec='ssh targetname' --target-path=/build/root/on/target
>> to your configure options.  Then "make test" should run the tests on the
>> target device.  You can override those parameters on the make command line
>> using the names TARGET_EXEC and TARGET_PATH.
> OK, I will try  that tomorrow.

OK, I just tried it, but it is not working.
I ran make test after specifying the target exec and path
I have an error:

ffmpeg_g -y -flags +bitexact -dct fastint -idct simple -sws_flags
+accurate_rnd+bitexact -f image2 -vcodec pgmyuv -i
/root/applications/tests/vsynth1/%02d.pgm -an -f rawvideo
make: *** [regtest-ref] Erreur 255

When I am lauching this exact command through ssh, with the same command
line than make test, it works.

Can you help about this ?

More information about the ffmpeg-devel mailing list