[MPlayer-dev-eng] [PATCH] Direct3D libvo driver

Uoti Urpala uoti.urpala at pp1.inet.fi
Wed Nov 19 22:20:36 CET 2008


On Wed, 2008-11-19 at 22:58 +0200, Georgi Petrov wrote:
> I've changed the name of all variables and functions according to your
> coding style. It wasn't easy, but I want to follow MPlayer's coding
> style as close as possible.

If you're really trying to use a standard style "as close as possible"
there are a couple of other things:

+static void calc_panscan_rect (void)

should be

+static void calc_panscan_rect(void)

There should be no space between the function name and left parenthesis
in function calls and declarations (the current direct3d code is
inconsistent and sometimes has the extra space, sometimes not).


     if (vo_panscan_x != 0 || vo_panscan_y != 0)
     {

should be

     if (vo_panscan_x != 0 || vo_panscan_y != 0) {

The opening brace of a for/while/if statement should be on the same
line. Currently you seem to consistently use an extra line for it.




More information about the MPlayer-dev-eng mailing list