[MPlayer-dev-eng] [PATCH] ve_lavc cosmetics

Michael Niedermayer michaelni at gmx.at
Mon Feb 13 00:39:21 CET 2006


Hi

On Sun, Feb 12, 2006 at 03:51:51PM -0500, Rich Felker wrote:
[...]

> The idea that whitespace should conform to a single 'coding style'
> rule is IMO very misguided. The purpose of whitespace is to break the
> logical units (logical in terms of how humans think about it, not how
> the machine things) up in a way that makes them easier to read. This
> depends on the semantics of the code, not the syntax.

yes, i fully agree
here are a few more examples which would be literally obfuscated if
they where are automatically reformated

ff_h263_encode_motion_vector(s, s->current_picture.motion_val[0][ s->block_index[i] ][0] - pred_x,
                                s->current_picture.motion_val[0][ s->block_index[i] ][1] - pred_y, s->f_code);


s->dsp.h263_v_loop_filter(dest_y  ,   linesize, qp_tc);
s->dsp.h263_v_loop_filter(dest_y+8,   linesize, qp_tc);
s->dsp.h263_v_loop_filter(dest_cb , uvlinesize, chroma_qp);
s->dsp.h263_v_loop_filter(dest_cr , uvlinesize, chroma_qp);


bits=bits* 4+3;    len+=2; //esc3
bits=bits* 2+last; len++;
bits=bits*64+run;  len+=6;
bits=bits* 2+1;    len++;  //marker

[...]

-- 
Michael




More information about the MPlayer-dev-eng mailing list