[FFmpeg-devel] [PATCH 1/6] lavf/tls_mbedtls: handle more error codes for human-readable message

Andrew Sayers ffmpeg-devel at pileofstuff.org
Fri May 17 12:42:58 EEST 2024


On Fri, May 17, 2024 at 10:34:26AM +0200, Sfan5 wrote:
> Signed-off-by: sfan5 <sfan5 at live.de>
> ---
>  libavformat/tls_mbedtls.c | 6 ++++++
>  1 file changed, 6 insertions(+)
> 
> diff --git a/libavformat/tls_mbedtls.c b/libavformat/tls_mbedtls.c
> index 1a182e735e..fd6ba0b1f5 100644
> --- a/libavformat/tls_mbedtls.c
> +++ b/libavformat/tls_mbedtls.c
> @@ -138,6 +138,9 @@ static void handle_handshake_error(URLContext *h, int
> ret)
>      case MBEDTLS_ERR_SSL_HANDSHAKE_FAILURE:
>          av_log(h, AV_LOG_ERROR, "TLS handshake failed.\n");
>          break;
> +    case MBEDTLS_ERR_SSL_BAD_PROTOCOL_VERSION:
> +        av_log(h, AV_LOG_ERROR, "TLS protocol version mismatches.\n");

"... mismatch" or "... does not match" would be more readable than "mismatches".

The word "matches" can mean either "does match" or "plural of match".
It's technically valid to use "mismatches" to mean "does not match",
but in practice the word is only ever used to mean "plural of mismatch".


More information about the ffmpeg-devel mailing list