[FFmpeg-devel] [PATCH] lavfi: add erosion & dilation filter
James Almer
jamrial at gmail.com
Thu Feb 26 23:50:27 CET 2015
On 25/02/15 11:55 AM, Paul B Mahol wrote:
> +static inline void line_copy8(uint8_t *line, const uint8_t *srcp, int width, int mergin)
Unless I'm missing something, "mergin" seems to always be 1.
The code below could be simplified.
> +{
> + memcpy(line, srcp, width);
> +
> + for (int i = mergin; i > 0; i--) {
> + line[-i] = line[i];
> + line[width - 1 + i] = line[width - 1 - i];
> + }
> +}
More information about the ffmpeg-devel
mailing list