[FFmpeg-devel] [PATCH 09/12] Change the order of parameters for ff_parse_and_eval_expr(), place the names before the values.
Michael Niedermayer
michaelni
Sun May 9 23:44:15 CEST 2010
On Mon, Apr 12, 2010 at 12:37:58AM +0200, Stefano Sabatini wrote:
> This looks more readable, as the user is expected to know the names
> before the values, the other order looks awkward.
[...]
> else if(!strcmp(buf, "none" )) d= 0;
> else if(!strcmp(buf, "all" )) d= ~0;
> else {
> - ff_parse_and_eval_expr(&d, const_values, const_names, NULL, NULL, NULL, NULL, NULL, &error);
> + ret = ff_parse_and_eval_expr(&d, buf, const_names, const_values, NULL, NULL, NULL, NULL, NULL, obj);
> if (isnan(d)) {
> av_log(obj, AV_LOG_ERROR, "Unable to parse option value \"%s\"\n", val);
> - return AVERROR(EINVAL);
> + return ret;
> }
> }
is this change supposed to be in this patch?
[...]
--
Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB
Republics decline into democracies and democracies degenerate into
despotisms. -- Aristotle
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20100509/9bb9a910/attachment.pgp>
More information about the ffmpeg-devel
mailing list