On Fri, 21 Aug 2015 20:11:09 -0700 Philip Langdale <philipl@overt.org> wrote:
From: Philip Langdale <philipl@cloudera.com>
mplayer was switched to the new api a while ago, but retained traces of it in a few places - primarily through retaining vdpau_render_state as a trivial wrapper for a VdpVideoSurface.
This change removes all these remaining traces.
Hi, thanks for your patch. I attached a new version with this changes: - store the surface as VdpVideoSurface instead of uint32_t - in vd_ffmpeg renames use_hwaccel to use_vdpau for clarity - some additional cleanup in vd_ffmpeg - remove the ff*vdpauold codecs from codec.conf Work for me with and without vdpau. I haven't checked compilation without vdpau, but should be ok. Ciao, Roberto