[rtmpdump] please help

Etiam etiam.public at gmail.com
Sun May 4 14:29:44 CEST 2014

compn said the following on 2014-05-03 15:28:
> On Thu, 01 May 2014 19:27:46 +0200
> Etiam <etiam.public at gmail.com> wrote:
>> If anyone here knows a way to /fully/ resolve the issue and get a
>> downloaded file with intact video, I would be most interested to learn
>> of it as well.
>> /Etiam
> ffmpeg and videolan both have their own rtmp network code. you should
> try both of them to see if the bug exists with them. watch out i think
> ffmpeg can be compiled against librtmp so be aware of that.
> -compn
Thanks for the tip! I have tried to dump the streams using both vlc and
ffmpeg previously, with similar results, but I don't remember ever being
aware that ffmpeg could handle rtmp even when built with disabled librtmp.
I have tried that now, and unfortunately that also suffers from the
problem of a lot of lost video frames. (At least when using '-acodec
copy -vcodec copy' as the options. I doubt adding other options could
fix this, but I would be happy to be proven wrong.)

Actually, I really ought to file a bug report for this. I tried around
the time I first encountered the problem, but didn't manage to find the
right place then. Clearly this is not purely an issue with rtmpdump, but
I'm not well equipped to find out what or where the problem is. Thoughts
on where to file this, anyone?


More information about the rtmpdump mailing list