[rtmpdump] RTMPDump - Segmentation Fault

Matt Hughes matthyo at gmail.com
Wed Dec 12 06:34:35 CET 2012

I spoke too soon,
On my ubuntu 10.10 machine, running rtmpdump from the build dir produced a
seg fault, and then running checkinstall fixed it, but I just tried doing
checkinstall on my 12.04 machine and it still produces a seg fault

htpc at myth-htpc:~$ rtmpdump
> RTMPDump 2.4.19d3636~git
> (c) 2010 Andrej Stepanchuk, Howard Chu, The Flvstreamer Team; license: GPL
> Segmentation fault (core dumped)

On Wed, Dec 12, 2012 at 12:03 AM, Matt Hughes <matthyo at gmail.com> wrote:

> Yeh the problem was I wasn't doing "make install"
> I used checkinstall and it seems to be working fine now
> I like to test compiles in the build dir before I install and never had a
> problem doing it like that before
> On Tue, Dec 11, 2012 at 11:31 PM, Steven Penny <svnpenn at gmail.com> wrote:
>> On Tue, Dec 11, 2012 at 9:50 PM, NhJm wrote:
>> > rtmpdump is probably loading an old shared library instead of the
>> > local one.. please `make install`!
>> Or better yet avoid "dll hell" and do static build
>>   make SHARED=
>> _______________________________________________
>> rtmpdump mailing list
>> rtmpdump at mplayerhq.hu
>> https://lists.mplayerhq.hu/mailman/listinfo/rtmpdump
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mplayerhq.hu/pipermail/rtmpdump/attachments/20121212/7870f4df/attachment.html>

More information about the rtmpdump mailing list