[rtmpdump] ? Regression in 2.4

Alun Jones alun at wftpd.com
Wed Aug 31 22:12:36 CEST 2011

One issue I've noticed with streaming BBC TV is that I'll occasionally hit a 100% CPU loop (OK, 25%, but it's on a 4-core).

Before entering the loop, it emits a message like this:

DEBUG: RTMPSockBuf_Fill, recv returned -1. GetSockError(): 10060 (Unknown error)
ERROR: RTMP_ReadPacket, failed to read RTMP packet header

10060 is ETIMEDOUT in Windows.

I also see the occasional:

ERROR: WriteN, RTMP send error 10054 (42 bytes)
ERROR: RTMP_ReadPacket, failed to read RTMP packet body. len: 76711

This seems to be handled by closing the connection and being prepared to resume the transfer, but when I resume I get:
WARNING: Stream does not start with requested frame, ignoring data...
Over and over and over again until it gives up.


> -----Original Message-----
> From: Aardvark [mailto:brian at grumpy.me.uk]
> Sent: Tuesday, August 30, 2011 5:52 AM
> To: rtmpdump at mplayerhq.hu
> Subject: [rtmpdump] ? Regression in 2.4
> I have used rtmpdump to stream BBC tv via get_iplayer. This worked fine
> with v
> 2.3 but fails with the latest git. I suspect that this is confirmation of the
> problem reported by Philip Walden on 13 Aug but I haven't yet worked out
> how
> to get debug info.

More information about the rtmpdump mailing list