[rtmpdump] Special characters in playlist names.

bat guano batguano999 at hotmail.com
Fri Apr 29 10:11:11 CEST 2011

Using Ubuntu Linux I tried to download a video with this command:-
rtmpdump -r "rtmpe://cp3547.edgefcs.net:1935/ondemand?ovpfv=2.1.4" -a "ondemand?ovpfv=2.1.4" -f "LNX 10,1,102,64" -W "http://media.mtvnservices.com/player/release/?v=4.13.0" -p "http://www.cmt.com/videos/aaron-lewis/643964/country-boy-live-from-nashville.jhtml" -C Z: -y "mp4:mtvnshrdstor/_!/mtvi/bands/l/lewis_aaron/cm_country_boy_live_full_512x288_750_m30.mp4" -o cm_country_boy_live_full_512x288_750_m30.flv

But I got an error message:-
bash: !/mtvi/bands/l/lewis_aaron/cm_country_boy_live_full_512x288_750_m30.mp4": event not found

Then I tried again on a Windows machine and it downloaded OK.

It's because ! is a special character in bash.
So I had to put the -y name in 'single quotes' instead of "double quotes".
Then it downloaded OK in Linux.

I won't fall for that again, lol.

But could the rtmpsrv program be modified so that it always used single quotes in playpath names?
Or would it cause other complications?

More information about the rtmpdump mailing list