[rtmpdump] rtmpsuck Segmentation Fault

Francisco Legaspi silverbolt28 at ignmail.com
Sun Feb 14 07:10:47 CET 2010


I have been trying to use rtmpsuck to capture the Flash video from this Web site:
It's a region-locked Web site, but it can be accessed by changing your Web browser's
user agent to Googlebot. Also, when rtmpsuck is running, it takes a while for
the video to start playing, so give it some time.

I have gotten rtmpsuck working to the point where it actually writes an output file,
but one of two things always happens:
1. The video stops playing after a few seconds.
2. The video plays until the end, but rtmpsuck ends with a segmentation fault.
In both cases, only a fraction of a second of video (around 128 KB of data) gets
written to the file.

I am currently running rtmpsuck r247 on Ubuntu 9.10 in a VirtualBox VM, but I have also
tried it on real PC hardware. 2.1c has the same problems mentioned above. r248 and r249
both get HTTP 304 errors for hashswf, and the video never starts playing. I have also
tried 2.1b and 2.1, and the video never starts playing when using those versions.

Here is the output to the terminal window:
Processing connect
app: uliza1.0.3/5/
flashVer: LNX 10,0,45,2
swfUrl: http://www.uliza.jp/Player/98.swf
tcUrl: rtmpe://stream.uliza.jp/uliza1.0.3/5/
pageUrl: http://fod.fujitv.co.jp/FOD/index.asp
Playpath: mp4:13_4163_4163000361_KWHMVWAQICNYMIBDFREJ_22968_2000000_1280_720_11_
Saving as: mp4_13_4163_4163000361_KWHMVWAQICNYMIBDFREJ_22968_2000000_1280_720_11_
WARNING: ignoring too small audio packet: size: 0
  duration              60.10
  moovPosition          28.00
  width                 1280.00
  height                720.00
  videocodecid          avc1
  audiocodecid          mp4a
  avcprofile            100.00
  avclevel              31.00
  aacaot                2.00
  videoframerate        30.00
  audiosamplerate       48000.00
  audiochannels         2.00
  length                1803.00
  timescale             30.00
  language              und
  sampletype            avc1
  length                2883584.00
  timescale             48000.00
  language              und
  sampletype            mp4a
  length                5409000.00
  timescale             90000.00
  language              und
  length                2894848.00
  timescale             48000.00
  language              und
Segmentation fault

I tried to do a debug run, but the video never plays completely when rtmpsuck is in debug mode.

Any assistance with this is greatly appreciated.

Upgrade to Premium IGN Email
- 15MB of space
- No ads!
- Pop3 Downloads

More information about the rtmpdump mailing list