[MPlayer-users] playing mpegts

Gerhard Strangar g.s at arcor.de
Mon Sep 20 20:12:18 EEST 2021


mplayer told me to report a bug, however, I'm not sure if it's an
mplayer bug.

I tried to play a live stream from an m3u file. Since mplayer doesn't
want to play it directly, I tried piping it into mplayer:

ffmpeg -i
-c copy -f mpegts -map 0:7 -map 0:8 - | mplayer -cache 2048 -

And it seems to be working fine, I just get flooded with "Bad stream
state, please report as bug!".
With a different stream (that requires logging in), I'm out of luck.
It's a 50 FPS stream and the video seems to be playing at 100 FPS,
whereas the audio is normal. This causes the video to pause, then play
at 100 FPS again and so on.

I thought it might be because of the pipe, but when I use ffmpeg to copy
it to a file, mplayer shows the same behaviour. What does work is
letting ffmpeg write a matroska file and play that while it's still
being written.

ffmpeg 4.4_3,1 on FreeBSD x64
mplayer built from mplayer-export-2021-09-20


More information about the MPlayer-users mailing list