[MPlayer-users] compile failed

Masaru Nomiya nomiya at galaxy.dti.ne.jp
Mon Sep 25 11:22:30 EEST 2017


In the Message; 

  Subject    : Re: [MPlayer-users] compile failed
  Message-ID : <579B1780-8317-4D69-A55E-C30424FE79BF at gmx.de>
  Date & Time: Mon, 25 Sep 2017 00:24:45 +0200

Reimar Döffinger <Reimar.Doeffinger at gmx.de> has written:

> On 24.09.2017, at 05:02, Masaru Nomiya <nomiya at galaxy.dti.ne.jp> wrote:

> > Hello,
> > 
> > I got the very latest svn head, then tried to compile.
> > But, I got errors;
> > 
> > thread -ldl -rdynamic -L/usr/lib64 -L/opt/kde3/lib64 -L/usr/local/lib64 -ldvdnav -lpthread   -lm   -ltwolame -lfaac -lx264 -lpthread -lmp3lame
> > ffmpeg/libavcodec/libavcodec.a(v4l2_m2m_dec.o): In function `v4l2_receive_frame':
> > /tmp/nom/mplayer/ffmpeg/libavcodec/v4l2_m2m_dec.c:157: undefined reference to `ff_v4l2_context_dequeue_frame'

> Strange, is this on Linux?

Yes, on Linux.

> Either way I expect it is fixed by disabling these files as they
> caused issues on non-Linux systems, so they are disabled for now.

> They won't be interesting for the vast majority of users anyway.

I executed 'svn up', then the configure script was updated.
This solved the problem.


┏━━┓彡 Masaru Nomiya             mail-to: nomiya @ galaxy.dti.ne.jp
┗━━┛ "Bill! You married with Computers.
          Not with Me!"
         "No..., with money."

More information about the MPlayer-users mailing list