[MPlayer-users] MPlayer not playing HTTP video stream for one specific content from the same source

Joel Ng blood_elves88 at yahoo.com.sg
Tue Jul 4 10:43:09 EEST 2017

 > Ok, so it really is play H264-ES, that is a bit weird and won't
 > be very reliable.
 > I can reproduce the (or at least some) issue piping via stdin...
 > I haven't checked much, but going by those tests you need to either
 > use a larger -cache value or explicitly specify the format it should
 > interpret it as: "-demuxer h264es"

Hi, using either one of the options worked great!

> Just to double-check, did you actually pipe it?
> Or did you do something like:
> mplayer -noconsolecontrols  - < stream.dump
> That one doesn't behave like the streaming case, because
> MPlayer actually gets full access to the file.
> You need to do it the way that normally is considered
> horrible style (because it needlessly can create issues):
> cat stream.dump | mplayer -noconsolecontrols  -

I used the input redirection method (<).

I went to use the "cat" command method a few minutes ago and it says the 

MPlayer 1.1-4.8 (C) 2000-2012 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote 

Playing -.
Reading from stdin...
libavformat version 54.20.4 (external)
Mismatching header version 54.20.3
Cannot seek backward in linear streams!
Seek failed

Anyway, since the video can now be played, I will consider my problem 
solved. If you need more info to improve the autodetection (logs, etc.), 
feel free to ask.

Thanks for the help.

More information about the MPlayer-users mailing list