[MPlayer-users] how do you specify the path in mplayer's "mf:" parameter - verbose output included

Stephen Mollett molletts at yahoo.com
Wed Jul 6 20:56:35 CEST 2016

Hi Dave,

On 04/07/16 23:17, David Hepburn wrote:
>> ... have you tried using forward slashes in the path ...
> yep tried that - still gets ignored...

Hm, interesting. I've borrowed a Windows laptop from a friend and had a
poke around.

It seems that part of MPlayer recognises either forward- or backslashes
- it correctly says:

[mf] number of files: 1 (4)

when the file exists but then the demuxer crashes with a segmentation
fault, unless the file also exists in the current working directory, in
which case it uses that copy instead. (It works fine on Linux so it's
definitely related to running on Windows.)

I've included the output of mplayer -v for the segfault case. It doesn't
look terribly informative to me. Anyone with a knowledge of the code
base and the necessary Windows toolchain who feels like poking around -
see the end of this message.

As a workaround, you might be able to use a wrapper script - a batch
file to change directory to where the image is, call MPlayer from there,
then change back afterwards. Something like this might work:

---- Start mp.cmd ----

@echo off

pushd "%~dp1"

"C:\folder1\mplayer.exe" "mf://%~nx1" -mf fps=1 -loop 425


---- End mp.cmd ----

Just call the batch file with the name of the media file as its argument
and it should work.

That's obviously a very basic case which isn't very flexible but it
might point you in the right direction. (You could use "shift" to go
through a list of files provided on the command line. The "%~dp1" pulls
out the drive letter and path from "%1" and the "%~nx1" gets the
filename and extension. Unfortunately, you can't use these operators
directly on normal variables but but you could use a dummy "for" loop to
apply them to a variable - they do work on the the pseudo-variables in a
for loop.)


---- mplayer -v output ----

MPlayer sherpya-r37875+gce466d0-5.4.0 (C) 2000-2016 MPlayer Team

CPU vendor name: GenuineIntel  max cpuid level: 2

CPU: Intel(R) Celeron(R) M processor         1.40GHz (Family: 6, Model:
13, Stepping: 8)

extended cpuid-level: 8

extended cache-info: 67125312

Detected cache-line size is 64 bytes

Testing OS support for SSE... yes.

CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNowExt: 0 SSE: 1 SSE2: 1 SSE3: 0
SSSE3: 0 SSE4: 0 SSE4.2: 0 AVX: 0

Compiled with runtime CPU detection.

Setting PATH to

get_path('codecs.conf') ->

Reading optional codecs config file
No such file or directory

Using built-in default codecs.conf.


Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay

get_path('fonts') ->

Configuration: --prefix=/invalid --host-cc=gcc --cc=i686-w64-mingw32-gcc
--as=i686-w64-mingw32-as --ar=i686-w64-mingw32-ar
--nm=i686-w64-mingw32-nm --ranlib=i686-w64-mingw32-ranlib
--windres=i686-w64-mingw32-windres --enable-cross-compile
--enable-runtime-cpudetection --enable-static --enable-postproc
--disable-vidix --disable-inet6 --enable-gnutls --enable-dvdnav
--enable-dvdread --enable-bluray --enable-menu --enable-faac
--disable-faac-lavc --enable-libfdk-aac
--extra-cflags=-I/usr/i686-w64-mingw32/live --with-arch=i486
--with-tune=generic --disable-fast-clz

CommandLine: '-v' 'mf://E:/My Stuff/nobrain.jpg' '-mf' 'fps=1' '-loop' '10'

Using Windows native timing

get_path('input.conf') ->

Parsing input config file

Input config file
parsed: 92 binds

get_path('nobrain.jpg.conf') ->

Playing mf://E:/My Stuff/nobrain.jpg.

get_path('sub/') ->

WINSOCK2 init: 0

STREAM: [mf] mf://E:/My Stuff/nobrain.jpg

STREAM: Description: Multiple files input

STREAM: Author: Benjamin Zores, Albeu

STREAM: Comment:

MF file format detected.

[mf] search expr: E:/My Stuff/nobrain.jpg*

[mf] number of files: 1 (4)

Fontconfig warning: line 146: blank doesn't take any effect anymore.
please remove it from your fonts.conf

MPlayer interrupted by signal 11 in module: demux_open

- MPlayer crashed by bad usage of CPU/FPU/RAM.

  Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and

  disassembly. Details in

- MPlayer crashed. This shouldn't happen.

  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your

  gcc version. If you think it's MPlayer's fault, please read

  DOCS/HTML/en/bugreports.html and follow the instructions there. We
can't and

  won't help unless you provide this information when reporting a
possible bug.

More information about the MPlayer-users mailing list