[MPlayer-users] Cache empty, consider increasing -cache and/or -cache-min. [performance issue]

Jim Cross jimgcross at gmail.com
Fri Oct 24 10:47:28 CEST 2014

I have compiled and can run SVN-r37303-4.6 (thanks for your help Erik.). I
have not yet run make install to create the simlink as I want to make sure
the new version works OK. So for now, I can still run my current (old) ver
and the new one fairly easily.

However, I can't find how to setup the audio for the new version?
The error shows:
"[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or
Failed to initialize audio driver 'oss'"

The old version uses the directory '/dev/snd/' to find the audio device.
Don't know how to setup or change the new version...

Also, the old version I use Alsa driver which is listed using '-ao help'
but the new version does not list this driver. I tried './configure
--enable-alsa' but don't know if this is valid and anyways it didn't work,
should it?
So I am not sure if using the oss will work until I can fix the 'Can't open
audio device /dev/dsp: No such file or directory'.

Just for completeness:
~/mplayer/mplayer -ao oss http://ai-radio.org:8000/radio.opus
I get 'Starting playback...' - obviously this will be video only. However,
it's only a RPi so I get the "Cache empty, consider increasing -cache
and/or -cache-min. [performance issue]" errors - the good news is I'm not
interested in video.... So:
~/mplayer/mplayer -novideo -ao oss http://ai-radio.org:8000/radio.opus
However, no sound (and no video) = does not play :(

On Thu, Oct 23, 2014 at 11:28 PM, Andy Furniss <adf.lists at gmail.com> wrote:

> Reimar Döffinger wrote:
>> On Thu, Oct 23, 2014 at 10:57:21PM +0200, Reimar Döffinger wrote:
>>> On Thu, Oct 23, 2014 at 01:52:21PM +0100, Andy Furniss wrote:
>>>> Erik Auerswald wrote:
>>>>> Hi,
>>>>> On Thu, Oct 23, 2014 at 12:48:15PM +0100, Jim Cross wrote:
>>>>>> I have quite a few example audio streams that I can not get to play
>>>>>> using
>>>>>> MPlayer, although the streams work in chrome's browser.
>>>>>> As one example, I have tried the below 'playlist' file (or it's
>>>>>> contents)
>>>>>> but get the further below (typical) output.
>>>>>> I have tried many options with and without -cache sizes together
>>>>>> with/without many -cache-min values.
>>>>>> Could this be a bug (in the current version I'm using?) or is there
>>>>>> another
>>>>>> option that can be applied to get the stream to start playing?:
>>>>>> http://dir.xiph.org/listen/1467960/listen.m3u
>>>>>> http://ai-radio.org:8000/radio.opus
>>>>> I get the error message:
>>>>>    Ogg stream 0 is of an unknown type
>>>> Me too, but if I save the stream with wget, mplayer will play the file
>>>> OK
>>>> (and display a logo).
>>> That seems suspicious. I think this might be due to us using different
>>> default demuxers for Ogg, since the FFmpeg one (used to/does?) work
>>> rather badly for streaming.
>>> An explicit -demuxer lavf works.
>>> Assuming your FFmpeg version that MPlayer uses is new enough.
>> Starting with r37304 it should work (mostly?) without -demuxer lavf.
> Oops, you are right - I wasn't up to date.
> With updated svn both links work, though I only see the logo with -demuxer
> lavf.
> _______________________________________________
> MPlayer-users mailing list
> MPlayer-users at mplayerhq.hu
> https://lists.mplayerhq.hu/mailman/listinfo/mplayer-users

More information about the MPlayer-users mailing list