[MPlayer-users] Cache empty, consider increasing -cache and/or -cache-min. [performance issue]

Reimar Döffinger Reimar.Doeffinger at gmx.de
Thu Oct 23 22:57:21 CEST 2014

On Thu, Oct 23, 2014 at 01:52:21PM +0100, Andy Furniss wrote:
> Erik Auerswald wrote:
> >Hi,
> >
> >On Thu, Oct 23, 2014 at 12:48:15PM +0100, Jim Cross wrote:
> >>I have quite a few example audio streams that I can not get to play using
> >>MPlayer, although the streams work in chrome's browser.
> >>
> >>As one example, I have tried the below 'playlist' file (or it's contents)
> >>but get the further below (typical) output.
> >>I have tried many options with and without -cache sizes together
> >>with/without many -cache-min values.
> >>
> >>Could this be a bug (in the current version I'm using?) or is there another
> >>option that can be applied to get the stream to start playing?:
> >>
> >>http://dir.xiph.org/listen/1467960/listen.m3u
> >>http://ai-radio.org:8000/radio.opus
> >
> >I get the error message:
> >
> >   Ogg stream 0 is of an unknown type
> Me too, but if I save the stream with wget, mplayer will play the file OK
> (and display a logo).

That seems suspicious. I think this might be due to us using different
default demuxers for Ogg, since the FFmpeg one (used to/does?) work
rather badly for streaming.
An explicit -demuxer lavf works.
Assuming your FFmpeg version that MPlayer uses is new enough.

More information about the MPlayer-users mailing list