[MPlayer-users] Cache empty, consider increasing -cache and/or -cache-min. [performance issue]

Jim Cross jimgcross at gmail.com
Thu Oct 23 15:11:43 CEST 2014

I have just tried wget as follows. The output shows a moving '<=>' but I
get no sound (even using '-volume 70'). - As Erik's works, maybe a version
discrepancy as mine looks to be quite old?

Maybe it is a codec issue as looking at previous posts the messages "Ogg
stream 0 is of an unknown type" and my "[ogg @ 0xb646f990]Codec not found"
make me suspicious this could be the case?:

$ wget http://ai-radio.org:8000/radio.opus | mplayer
--2014-10-23 14:04:42--  http://ai-radio.org:8000/radio.opus
Resolving ai-radio.org (ai-radio.org)..., 2a00:1630:2:1004::1
Connecting to ai-radio.org (ai-radio.org)||:8000... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [application/ogg]
Saving to: `radio.opus.8'

      ] 0           --.-K/s              MPlayer svn r34540 (Debian), built
with gcc-4.6 (C) 2000-2012 MPlayer Team
Usage:   mplayer [options] [url|path/]filename

Basic options: (complete list in the man page)
 -vo <drv>        select video output driver ('-vo help' for a list)
 -ao <drv>        select audio output driver ('-ao help' for a list)
 vcd://<trackno>  play (S)VCD (Super Video CD) track (raw device, no mount)
 dvd://<titleno>  play DVD title from device instead of plain file
 -alang/-slang    select DVD audio/subtitle language (by 2-char country
 -ss <position>   seek to given (seconds or hh:mm:ss) position
 -nosound         do not play sound
 -fs              fullscreen playback (or -vm, -zoom, details in the man
 -x <x> -y <y>    set display resolution (for use with -vm or -zoom)
 -sub <file>      specify subtitle file to use (also see -subfps, -subdelay)
 -playlist <file> specify playlist file
 -vid x -aid y    select video (x) and audio (y) stream to play
 -fps x -srate y  change video (x fps) and audio (y Hz) rate
 -pp <quality>    enable postprocessing filter (details in the man page)
 -framedrop       enable frame dropping (for slow machines)

Basic keys: (complete list in the man page, also check input.conf)
 <-  or  ->       seek backward/forward 10 seconds
 down or up       seek backward/forward  1 minute
 pgdown or pgup   seek backward/forward 10 minutes
 < or >           step backward/forward in playlist
 p or SPACE       pause movie (press any key to continue)
 q or ESC         stop playing and quit program
 + or -           adjust audio delay by +/- 0.1 second
 o                cycle OSD mode:  none / seekbar / seekbar + timer
 * or /           increase or decrease PCM volume
 x or z           adjust subtitle delay by +/- 0.1 second
 r or t           adjust subtitle position up/down, also see -vf expand

* *

    [          <=>
      ] 116,515     15.5K/s

On Thu, Oct 23, 2014 at 1:52 PM, Andy Furniss <adf.lists at gmail.com> wrote:

> Erik Auerswald wrote:
>> Hi,
>> On Thu, Oct 23, 2014 at 12:48:15PM +0100, Jim Cross wrote:
>>> I have quite a few example audio streams that I can not get to play using
>>> MPlayer, although the streams work in chrome's browser.
>>> As one example, I have tried the below 'playlist' file (or it's contents)
>>> but get the further below (typical) output.
>>> I have tried many options with and without -cache sizes together
>>> with/without many -cache-min values.
>>> Could this be a bug (in the current version I'm using?) or is there
>>> another
>>> option that can be applied to get the stream to start playing?:
>>> http://dir.xiph.org/listen/1467960/listen.m3u
>>> http://ai-radio.org:8000/radio.opus
>> I get the error message:
>>    Ogg stream 0 is of an unknown type
> Me too, but if I save the stream with wget, mplayer will play the file OK
> (and display a logo).
> _______________________________________________
> MPlayer-users mailing list
> MPlayer-users at mplayerhq.hu
> https://lists.mplayerhq.hu/mailman/listinfo/mplayer-users

More information about the MPlayer-users mailing list